Topic: No surround sound on Samsung Q80

Posts 1 to 3 of 3


Hey guys!
I have my Xbox plugged into the HMDI 2.1 port on my Samsung Q80 using a HDMI 2.1 cable. Then, I have an Optical cable going to my 5.1 audio receiver.

But, my Xbox only shows 2 options: "Dolby Digital" and "Stereo". I think it's actually "stereo uncompressed" or something like that.

Dolby Digital is useless, as it has a massive audio delay.
Stereo obviously utilize the surround sound.

It's very strange, because my PS5 has perfect Surround Sound when set up in the exact same way.

I've read about the "Pass Through" option, but it's "grayed out" on my TV. It is instead set to "Auto".

Any help, tips or tricks would be appreciated!



2nd Edit!! Sorry it just occured to me that the option of PCM should be set on the reciever!! not the telly as you are passing the sound to the Receiver not the TV. So ignore the samsung TV Link and try and change it on your Receiver if you can.

Any options on the TV to allow PCM? I think thats the most basic form of surround format that you can use as it doesnt use fancy encoding. If think if you can set it PCM you should be able to select 5.1 and 7.1 uncompressed PCM.

EDIT: found this on Samsung website.

This is some blurb on what PCM format is.

I think the PassThrough option is biststream?

I know how usless DD is with the massive delay fortunately my AV receiver can uses Atmos.

Edited on by Chuffer



@Chuffer Thanks so much for the help, I'll read those articles and try your suggestions! ^_^


  • Page 1 of 1

Please login or sign up to reply to this topic