Forums

Topic: New drive won’t eject

Posts 1 to 2 of 2

C64midrezzie

Got a new drive - transferred board - It accepts disks and loads disks but the eject button isn’t ejecting disks - instead it starts loading whatever disk is in the machine when I press it.

I tried using the controller to eject but again the drive makes a sound and starts loading the disk.

I can only remove disks manually.

The drive does eject as I had it in another Xbox one last night and it ejected perfectly.

I even tried a different eject ribbon cable with the same result.

Any ideas gracefully accepted

C64midrezzie

Vincent294

I wonder if the issue is on the board itself. Obviously since they marry a chip on the disc drive circuit board to the Xbox motherboard your options are limited. Maybe there is a visibly damaged component or you can use a multimeter to look for a short to ground that is present on one but not the other. I have not Googled this issue, and I have not seen many videos on disc drive repairs that weren't mechanical in nature. It's quite likely maybe something came loose during the transplant, that quite frankly is a more plausible explanation to me, but I am not an expert.

Vincent294

Xbox Gamertag: Vincent294

Top

  • Pages:
  • 1

Please login or sign up to reply to this topic